Component - för entusiaster av ljud och bild.

Hoppa till innehåll


Foto

Serviio


  • Vänligen logga in för att kunna svara
62 svar till detta ämne

#1 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 30 December 2011 - 12:43

Serviio is a free media server. It allows you to stream your media files (music, video or images) to renderer devices (e.g. a TV set, Bluray player, games console or mobile phone) on your connected home network.


Klicka här för att ladda ner
http://www.serviio.org/download

Klicka här för att komma till Serviio forum
http://forum.serviio.org/




Här fyller vi på med info om denna media server, tänkte att vi kunde ge varandra lite tips osv.
Använder den själv till att streama musik till min Onkyo 5007, och musik,film till min Oppo 93.

Börjar med en guide för att kunna köra RSS/Play kanaler till Oppo 93/95


Nedanstående guide skriven av chrme109
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Ok, det är ganska enkelt:

1. Ladda ner en plugin för den playtjänst som önskas, t.ex. svtplay. Alla färdiga plugins finns på Serviios eminenta forum. För svtplay finns pluginen som en bilaga i första inlägget här.
(Förtydligande av Niklas F, det är alltså filen som heter .Groovy )

2. Placera filen i mappen plugins i serviios katalogstruktur (Windows 7).
Normalt: "C:\Program Files (x86)\Serviio\plugins\"
För Mac användare finns det info här

3. Starta Serviio console. Välj fliken "Library" och sen fliken "Online sources". Klicka på knappen "Add"
Lägg till länken (url) för det RSS-flöde som önskas t.ex för "Film och drama": http://feeds.svtplay...full&mode=plain (klicka på länken och kopiera url'en)
Se till att "Media type" är satt till Video

4. Sätt "Preferred online content quality" till "High" annars ser det apa ut (det kan det göra ändå iof).

5. Klicka på Save.

6. Starta om tjänsten Serviio så att pluginen laddas.

7. Se till att "Online Feeds" visas under fliken "Presentation"

I oppon bör nu mappen "Online feeds" visas:
bild1.jpg

I denna mapp ska de RSS flöden som man lagt till i serviio visas:
bild2.jpg

Väljer man då t.ex. Film och drama så ser det ut så här:
bild3.jpg

Vill man designa sina egna RSS-flöden så kan man det. Kika på det nummer som finns i url'en för en svtplay sida. t.ex. har serien "Dom kallar oss artister" urlen:
http://svtplay.se/t/...ar_oss_skadisar

Lägger man numret 164074 i RSS-länken:
http://feeds.svtplay.se/v1/video/list/164074?expression=full&mode=plain
så får man flödet för denna serie. Bara att klistra in i Serviio enl. ovan.

Man kan även kombinera flera serier genom ett kommatecken mellan varje nummer.
Finns en hel del info (och andra plugins) på Serviios forum.

Mycket nöje!

/C

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


Här kommer lite länkar för playkanaler.
( ni kan väl fylla på med dom ni hittar så fixar jag att lägga till dom i första inlägget framöver )

SVT Play
http://forum.serviio...php?f=20&t=3338

TV4 Play
http://forum.serviio...php?f=20&t=3674

TV6 Play
http://forum.serviio...php?f=20&t=3468

TV8 Play
http://forum.serviio...php?f=20&t=3948
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#2 Tzimiche

    En glad entusiast.

  • Members
  • Pip
  • 50 inlägg

» Har inga bilder i mitt galleri

Postad 30 December 2011 - 15:54

Är det bara att köra med generic profilen? Det står att serviio ska supporta Oppo BDP-83 men det finns ingen profil att välja.

Får väl prova mig fram, fast det var problem med att få igång programmet men nu verkar det fungera.

#3 chrme109

    Music lover

  • Members
  • PipPip
  • 107 inlägg
  • Location:Linköping

» Har inga bilder i mitt galleri

Postad 30 December 2011 - 16:30

Bra med en egen tråd. :)

I tidigare versioner av Serviio så fanns det en profil för Oppo BDP-83. Den verkar dock vara borttagen. Dock så fungerar Generic bra eftersom ingen transkodning behövs. Oppon klarar sånt själv.

Det streamade materialet från playtjänsterna "tolkas" som mpeg2 av mediaspelarna.

Vill man så kan man göra en egen profil för Oppon. Alla profiler finns i filen "profiles.xml" i Serviios config-mapp. Enda anledningen till att göra en sådan skulle vara för att stödja separata undertexter. Jag har dock inte provat än... :rolleyes:

mvh

/C

#4 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 30 December 2011 - 16:53

Så egentligen skulle det inte vara några problem att få till .srt stöd via Serviio om jag tolkar dig rätt?
Eller måste det transcodas via datorn om man väljer detta?
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#5 nikeb

    nikeb

  • Members
  • PipPipPipPip
  • 749 inlägg
  • Location:Skara

» Har inga bilder i mitt galleri

Postad 30 December 2011 - 23:19

Niklas kan du på ren svenska säga exakt vad gör denna? Kan jag genom appar strema video från tex tv4play till min oppo som spelar upp det på projjen.

Med rätt app (som kanske inte finns än) ska det då gå att streama youtube och internetradio, samt spotify trådlöst direkt till oppon som får spela upp det?

Ursäkta att jag är en riktig noob på detta med dator i stereon.

Gott nytt år 2012 och må det bli året då ni alla får ett dedikerat musik/filmrum!
Allt har sin tid

#6 chrme109

    Music lover

  • Members
  • PipPip
  • 107 inlägg
  • Location:Linköping

» Har inga bilder i mitt galleri

Postad 30 December 2011 - 23:36

Nu är jag förvisso inte Niklas men i alla fall...

Niklas kan du på ren svenska säga exakt vad gör denna? Kan jag genom appar strema video från tex tv4play till min oppo som spelar upp det på projjen.


Japp, du kan streama från TV4Play via din dator (med Serviio installerat) till din Oppo. Serviio behöver en plugin för varje "play"- tjänst. Plugin finns för tv4play (se översta inlägget).

Med rätt app (som kanske inte finns än) ska det då gå att streama youtube och internetradio, samt spotify trådlöst direkt till oppon som får spela upp det?


Youtube plugin finns redan: YouTubePlugin
Internetradio ska också stödjas men inget jag har testat själv än. Spotify stöd finns inte i version 0.6 av Serviio.

mvh

/C

#7 Tzimiche

    En glad entusiast.

  • Members
  • Pip
  • 50 inlägg

» Har inga bilder i mitt galleri

Postad 31 December 2011 - 10:34

Bra med en egen tråd. :)

I tidigare versioner av Serviio så fanns det en profil för Oppo BDP-83. Den verkar dock vara borttagen. Dock så fungerar Generic bra eftersom ingen transkodning behövs. Oppon klarar sånt själv.

Det streamade materialet från playtjänsterna "tolkas" som mpeg2 av mediaspelarna.

Vill man så kan man göra en egen profil för Oppon. Alla profiler finns i filen "profiles.xml" i Serviios config-mapp. Enda anledningen till att göra en sådan skulle vara för att stödja separata undertexter. Jag har dock inte provat än... :rolleyes:

mvh

/C


Tack för det. Streamade lite film igår och det fungerade bra. Jag hittade något på Serviios forum som gör att man skulle kunna streama AVI med en Oppo profil. Jag försökte lägga in detta i profiles.xml men det fungerade inte alls. Hittade i alla fall ingen profil med Oppo att välja. Måste man lägga till den sist i listan? Jag ersatte helt sonika id14 som var WD TV Live men när Consoleprogrammet startade står det WD TV i alla fall.

Jag ska tillägga att jag har noll koll på vad jag gör :) Klipp och klistra mannen är i farten helt enkelt.

#8 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 31 December 2011 - 10:45

Se till att ni har transcoding urbockat i serviio så att Oppon sköter denna biten, så slipper ni att datorn gör galenskaper och så sköter oppon den biten som det är tänkt.
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#9 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 31 December 2011 - 10:49

Kan passa på att rekommendera er Teamviewer( eller liknade program ) då många utav oss har en stationär burk där Serviio står och snurrar på, samt en laptop som är smidig att ta med ner till mediarummet.
Då kan man sköta utdelningar och div inställningar ifrån laptopen för att sen kunna testa direkt på plats.

Teamviewer funkar även på iPhone,iPad,iPod.
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#10 Tzimiche

    En glad entusiast.

  • Members
  • Pip
  • 50 inlägg

» Har inga bilder i mitt galleri

Postad 31 December 2011 - 11:02

Se till att ni har transcoding urbockat i serviio så att Oppon sköter denna biten, så slipper ni att datorn gör galenskaper och så sköter oppon den biten som det är tänkt.


Det står "Transcoding only works with a specific render profile (not the Generic DLNA profile) Så då kvittar det väl om man har den i eller urbockad då jag kör mot Oppo som använder den "allmäna" profilen och ingen transcoding kommer att ske i vilket fall. Men visst kan man bocka ut den bara utifall.

Nu ville jag ju att Oppon skulle spela upp AVI vilket den inte verkar klara via nätverket, eller är det bara jag som gjort något fel? Den hittar helt enkelt inte filerna som slutar .avi. Därför ville jag försöka lägga in profilen som jag hittade på serviios forum som tillåter transcoding för AVI men det var där något gick snett.

Redigerat av Tzimiche, 31 December 2011 - 11:06.


#11 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 31 December 2011 - 11:14

Har nog bara provat med divx, och det lirade utan problem. Kan kika om jag hittar någon avi att testa med senare.
Just nu så bråkar min router här nere med mig så kommer inte ut på nätverket med Oppon, alltid är det något.
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#12 Tzimiche

    En glad entusiast.

  • Members
  • Pip
  • 50 inlägg

» Har inga bilder i mitt galleri

Postad 31 December 2011 - 11:32

Har nog bara provat med divx, och det lirade utan problem. Kan kika om jag hittar någon avi att testa med senare.
Just nu så bråkar min router här nere med mig så kommer inte ut på nätverket med Oppon, alltid är det något.


Nej livet är inte lättare nuförtiden med alla inställningar och hit och dit :(

Det var nog även divx eller kanske xvid jag provat? Eller så tar helt enkelt inte BDP-83an dessa över nätverket men de nyare 93 och 95 gör det?

#13 joakim

    En glad entusiast.

  • Members
  • PipPipPipPipPipPip
  • 1161 inlägg
  • Location:Stockholm

» Har 20 bilder i mitt galleri

Postad 31 December 2011 - 12:02

Jag hade lite strul med Serviio första gången jag testade det så jag tog bort det.
Nu testade jag igår igen med min WDTV live och vilken skillnad! Det gick att spola, lika snabbt som från min externa disk, bilden flöt på bra. Allt funkade klockrent. Kul!
Oppo BDP-93>Mac Air/Imac>Bladelius DAC->Onkyo PR-SC5507->Nuforce MCH-3SE-C7->Nordost Baldur->Martin Logan Spire, Martin Logan Theater-i, 4*SVS SSS02, SVS AS-EQ1-> 2 * SVS PC13-Ultra DSP

Imac->Apogee Duet->Moddade Denon AH-D7000
Mitt galleri

#14 NiklasF

    En glad entusiast.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2419 inlägg
  • Location:Trollhättan

» Har 16 bilder i mitt galleri

Postad 31 December 2011 - 12:39

Ok, 83 har jag ingen koll på alls vad den stöder eller inte. Kanske att du skall aktviera transcoding på din modell?
Martin Logan Sl3. Martin Logan Logos, Dubbla SVS PB13U, Focal sr800s,Onkyo TX 5007NR.
Nad 218 THX, Nordost Super Flatline Gold MkII,Epson TW3200,Kingpin 104",Oppo BDP93 Playstation3,Philips Pronto Ru950.

#15 Tzimiche

    En glad entusiast.

  • Members
  • Pip
  • 50 inlägg

» Har inga bilder i mitt galleri

Postad 31 December 2011 - 21:06

Nu fungerar avi med min oppo 83. Jag kunde välja profilen jag lagt in i profiles.xml efter omstart av datorn. Datorn kör transcodingen. Gott nytt år!